Search
Thursday, July 31, 2014 ..:: Home ::.. Register   Login
Welcome Guest! To enable all features please try to register or login.
craig
#1 Posted : Tuesday, April 12, 2011 11:40:12 PM(UTC)
craig

Rank: Member

Reputation:

Groups: Registered Users, Subscribers
Joined: 4/12/2011(UTC)
Posts: 19
Location: South Africa

Thanks: 5 times
  Allo allo. I'm a new Swordfish user and trade with CJS. Love the program  - was previously living in the Standard Bank online share trading universe so intraday candle charts are the best thing since sliced bread. These are some gremlins I've found so far:

1)  I found that when I add multiple MAs or EMAs to a chart and inadvertently apply two averages with the same period a strange result occurs. It also seems particular to the 90min time frame, but I could be wrong. Once the averages are added (even once the repeated average has been deleted) and one tries to select a MA/EMA line to change its colour or thickness, selecting one line selects them all.... It seems that its necessary to then delete the chart and recreate it to resolve the problem.

2) The default quantities on the buy and sell button seem to fluctuate randomly. I've found this quite alarming and have a few times almost taken 7 positions when 1 was intended. Should it not be a constant 1? Or perhaps the last quanity entered? There appears to be no pattern. Screen shot shows 13...(!)

3) The submit button on my sell popup looks a bit strange? See screenshot. Should it look like this? Also the follow price button should turn orange when selected, according to the documentation. Mine remains grey and the difference between on and off is not as clear as it could be. I would help a huge amount if it turned orange when on.

Screenshot is here

(https://docs.google.com/viewer?a=v&pid=explorer&chrome=true&srcid=0B0x6vlg6mHNMMTM1NGNmZjEtZjIwYS00NWFkLWI5ODctOGI3YzM5NDE3YTI4&hl=en&authkey=CLvlif0P)


Edited by user Wednesday, April 13, 2011 12:15:56 AM(UTC)  | Reason: Not specified

estuary
#2 Posted : Wednesday, April 13, 2011 4:17:01 PM(UTC)
estuary

Rank: Administration

Reputation:

Groups: Administration, Administrators, Registered Users, Subscribers
Joined: 1/9/2008(UTC)
Posts: 198
Location: South Africa

Thanks: 1 times
Was thanked: 12 time(s) in 10 post(s)
Hi Craig,

Thanks for the kind words.  Regarding the gremlins:

1.)  We haven't been able to duplicate this - perhaps you could make a screen shot of this.

2.) You can set a default order quantity on Swordfish by clicking on (from the main menu) 'Tools', 'Environment Options'.  On the Environment Options form there will be a tab relevant to the service(s) you are connected to.  For example, if you are connected to SAFEX Financials there will be an 'SXFIN' tab and you are able to set a default order quantity here.  Your current default quantity is zero, which means that if you open a Bid/Offer form and you are putting in a buy order, the quantity will default to the quantity of the best offer and vice versa.  As you say, it is better practice to set the default quantity to a value such as 1 and change it as necessary when entering the order to prevent costly mistakes.

3.) You have a larger font selected on Windows - this setting is controlled via 'Control Panel', 'Display' :


It seems that your setting is either 125% or 150%.  Unfortunately this has mixed results on applications - setting the value to 100% should resolve this.  The follow market button, when activated is orange in Windows XP (which was the operating system used at the time that portion of the help file was written) but remains grey in Windows 7.  The indication that the button is active in Windows 7 is that it will have a blue border.  If you hover the mouse over the button the tooltip text will also indicate whether or not the button is active.   We will, however, look at improving this and making the two states clearer.

Estuary

Edited by user Thursday, April 14, 2011 12:15:07 PM(UTC)  | Reason: Not specified

craig
#3 Posted : Thursday, April 14, 2011 4:33:57 PM(UTC)
craig

Rank: Member

Reputation:

Groups: Registered Users, Subscribers
Joined: 4/12/2011(UTC)
Posts: 19
Location: South Africa

Thanks: 5 times
Thanks. I've sorted the quantity issue.
I forgot to mention - I use Windows XP Professional. My buy button appears normal and is green, I imagine the sell button should look exactly the same, just red?

Here are some screen shots of the multiple line selection (I'm not too sure how to cause this, but as I said, it seems particular to the 90 minute period and occurs when adding mas & ema's, possibly when you duplicate the same period in the same indicator and then delete one and move the order of the inidicators up & down in the list.)

I also describe a problem with a 200 ma & ema on the 90 minute chart.

Screenshots

Thanks


Edited by user Thursday, April 14, 2011 4:35:42 PM(UTC)  | Reason: Not specified

Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Copyright 2007-2013 by Estuary Solutions   Terms Of Use  Privacy Statement